Welcome to www.arepo-code.org Forums Arepo forum The code is not working “strange zero count” error

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #565
    Alankar Dutta
    Participant

    Hi,
    I get the following error in one of my hydro setups on Arepo. Looks like there is some error in setting up proper geometry. Can anyone please suggest a way to sort this error and get the code running?

    task=72 flags=1 0 0 0  (axb)*c = 1.17124e-05
    task=72 pp0=172 pp1=-1 pp2=-3 pp3=152 p=173 IDs=(850214 0 0 850045 850044) pos_0=(836.5|256.75|288.25) pos_1=(2800|2800|28000) pos_2=(2800|26558.8|-5600) pos_3=(835.5|257|289.5) pos=(836.5|256.75|288.25)
    task=72 imageflags=(1 0 0 1 1)
    TERMINATE: ******!!!!!******  Code termination on task=72, function InTetra(), file /home/alankar/arepo-clcrush/arepo/src/mesh/voronoi/voronoi_3d.c, line 3136: strange zero count
    #571

    Is this happening directly after startup?
    If yes, check your cell positions, especially that no cell has a position < 0 or > BoxSize.
    And (via scatter plot or so) check if the cell positions fill your simulation volume and there
    is not some region entirely devoid of cells. Let me know if this solves the problem.

    #583
    Alankar Dutta
    Participant

    Hi Rainer,
    This is hapenning right on start up.
    I increased the box size to a value bit larger than the xmax, ymax and zmax values in the IC file. Now the code runs but there is no progress beyond
    DOMAIN: Peano-Hilbert order done, took 0.052613 sec.
    Arepo just keeps on running without any progress until the entire job execution time.
    I wish to share the links to the IC, output dump, and param files but the forum doesn’t allow that. Please let me know if there is an alternative.

    #586
    Alankar Dutta
    Participant

    But in all cases, I have ensured that boxsize is not sharter than the boxsize in the IC file. But I still get the same error.

    #590

    could you send me ICs, Config.sh and param.txt directly via email (see contact) or upload it to a could storage that I can access? I can have a look at it.

    #591
    Alankar Dutta
    Participant

    Thanks a lot Rainer. For some unknown reason when I pasted this link, the post doesn’t show up in the forum. I have shared you the link via e-mail.

    #592

    It seems like there are two cells (i.e. two mesh generating points, pos0 and pos in error message) with identical coordinates. This is not allowed in the Voronoi-construction. Check your ICs for this.

    #594
    Alankar Dutta
    Participant

    Yes, you were right. Turns out these identical points were due to some data truncation error. Datatype specification was making the points identical in the python code that I used to generate the IC. This has been corrected and the issue is fixed. However, now the code doesn’t proceed beyond the following message (you can get it in output-log.txt). The code just keeps on running. It has been more than 10 hours but the code doesn’t progress beyond this message.
    DOMAIN: Peano-Hilbert order done, took 0.594324 sec.
    Relevant files had been shared by email as the form doesn’t support posting the link.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.