Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #555
    Alankar Dutta
    Participant

    Hi,
    I checked that if I wish to dump Xdmf file in Arepo, what it does is that it creates a xmf file and a hdf5 file both in the same directory. However, inside the xmf file, I see that it expects the hdf5 file inside a ./output/ directory. This creates an error on trying to read it on visualization tools like Paraview. This is solved by manually creating an output directory and moving the hdf5 files there. Is there a quick fix in the code to resolve this issue?

    <?xml version="1.0" ?>
    <!DOCTYPE Xdmf SYSTEM "Xdmf.dtd" []>
    <Xdmf Version="2.0">
     <Domain>  <Grid Name="PartType0" GridType="Uniform">
       <Topology TopologyType="Polyvertex" NumberOfElements="10000"/>
       <Geometry GeometryType="XYZ">
        <DataItem Dimensions="10000 3" NumberType="Float" Precision="8" Format="HDF">
         ./output/snap_040.hdf5:/PartType0/Coordinates
        </DataItem>
       </Geometry>
       <Attribute Name="Velocities" AttributeType="Vector" Center="Node">
        <DataItem Dimensions="10000 3" NumberType="Float" Precision="8" Format="HDF">
         ./output/snap_040.hdf5:/PartType0/Velocities
        </DataItem>
       </Attribute>
    • This topic was modified 2 months, 3 weeks ago by Alankar Dutta.
    #559

    Hi Alankar,
    Thanks for reporting this. This was indeed a bug, however only showing up if the output directory is not “./”. I just fixed this.
    Please let me know if you have further problems with this.

    Best,
    Rainer

    #560
    Alankar Dutta
    Participant

    Thanks Rainer for fixing the bug. This is now working fine.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.